cl A Brief Guide to Microsoft’s Expression Web for Web Authoring

Prior to Web Development
1. Email John Lefave and ask him to open an account on the QCC web server for a web site.

2. Your username and password will be the same as your QCC network login.
3. Email Help to have Expression Web installed remotely on your office machine OR request a
copy of the software for home use from Network Services.

Open Microsoft Expression Web
1. Select the Start button
2. All Programs
3. Microsoft Expression
4. Microsoft Expression Web

Open Your Web site

1. In Expression Web, under the Site menu, select Open Site to display the Open Site
dialog box.

2. Enter your URL in the Location box. This is going to be http://www.gcc.mass.edu/jdoe (your
first initial, then last name for a faculty site OR http://www.gcc.mass.edu/english (the chosen
department designation for a department)

3. Click Open at the bottom right.

g T=TE
Location: Ihttp://v\-v\"/\-.qcc.mass.edu/english Browse... I
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Managed Sites:
Name I Path ] Type I Date Modified ]
booth http: /fwww.gcc.mass.edu/booth HTTP 2/6/2012 12:43:48 PM
english http: /fwww.gcc.mass.edu/english HTTP 1/18/2012 11:51:00 AM
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3. When prompted, enter your network
User name and password as you would
to access your campus computer or your
campus e-mail account with an
important difference. Please notice in
the “User name” box that the User name
is preceded by QCCLAN (not case
sensitive) then a \ (back-slash) followed User name: !Q QCCLANYjdoe V{ ;
by your user name.

Connecting to calvin.gcc.mass.edu,

Password: l escscese l

[ Iremember my password

[ OK ][ Cancel ]

Default View
Once the site is open, you will be in the default view of Expression Web and you’ll want to
become familiar with the commonly used menu commands and tools of the software.

This “Title bar” displays the words of

the official page title as they appear in Use the Panels menu to display the

The Menus the browser window. Folder list on the left side.

M Sheila Booth, Student Writer's Web, Quinsigamond €Eommunity College (http://fwww.qcc.mass.edu/booth
File Edit View Insert Format Tools Table Site DataView Panels Window Help

A -EE- R o @5 - (I YT ET HOoe=

Folder List % x  Sie View  poetrylisthtml index.html
o e art

Notice how many of the menu names match those in Word and they do have similar functions.
In this introduction we’ll use File, View, Insert, Table and Panels.

First open the Folder list which will appear to the left of the window; users like to display this
since it’s easier to organize your site with folders, and you can open them to find the files you
wish to work on. Access the folders under the Panels menu or use the ALT + F1 keys. These
tools are toggle switches—open and close commands.

Many of the other features under Panels are more advanced. Manage Styles and Apply

Styles, for example, refer to Cascading style sheets which can be used to set the design for
fonts and tables in your documents. These panels appear to the left or right of the window
and may be closed either with the menu “toggle” or by using the X at the top of the panel.
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The File menu

File menu>New Page
Use the File menu (as in MS Word) to open a blank page to work on.

File menu>Properties

The Properties command leads you to identify your page title and description in the General tab
and colors of links and size of margins in the Formatting tab. The official page title is important to
identify your site to web search services.

General | Formatting | Advanced | Custom | Language |

Location: iﬁftb:ﬂw;Nw.qcc.mass.eduibo&fﬁkﬁaex.Html \
Title: 1h, VS?ud;nt Writgr'; Webr,iaui'ﬁrsigarmond Communiity Colleg;}
Page description: Teaching and learning resources for college writing, :A‘

literature, and Internet communications courses; ¥ |
Keywords: |Sheila Boath, writing, writing quides, essay, college, A |

'syllabus, Internet, Internet 101, authoring, web,

Base location: [

|

Default target frame: | | g I
| | wesl

Background sound

Loop: | [V]Forever

[ OK ] [ Cancel ]

Open a File --in the file list on the left or under File menu> Recent files.

1. If your site is newly created you can double-click on the file you would like to work on in the

list at the left, remembering that default.htm (or index.html) is your home page.

If you’ve been working on a file you may access it quickly under the File menu>Recent files.

2. At the bottom of the screen there are three buttons that allow you to change the view.
Design  Split Code

a. Design view is like working in Word (What You See is What You Get a.k.a. WYSIWYG).

b. Split view lets you see both the design view and the Code view at the same time. You can use

this view to edit the HTML code while being able to see where you are on the page.

c. Code view shows only the HTML code. You can edit the code directly here.
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Formatting Your Text

1. First select the text by highlighting, and then click your choice of buttons in the Formatting
Toolbar. Hover your cursor over a button to display an explanation of what that button will do.
Toolbar buttons let you change font face, font size, and text color. You can also make the text
bold, italics, or underlined. Most people think underlined text is a link, so use underlines as
little as possible.

Note: Common “web-safe” fonts are: Arial and Verdana. Common font sizes are: 8pt, 10pt,
12pt and 14pt.

2. Use Shift + ENTER to go to the next line, single spaced, or press the ENTER key for double
spacing.

3. As with any writing, it’s important to save frequently; the Save button should be next to the
open folder button. Click that button and then Yes if prompted whether you would like to save.
Save Often! You are working LIVE! You don’t want to lose unsaved work. In web authoring we
also need to preview the page in the web browser. The Preview button is next to the SP button
(an advanced feature) on the toolbar. Once the browser has opened, you should click the
Refresh button to view the latest saved version.

Save button

Preview button

File Edit View\ Insert Format/ Tools Table Site Data View Panels Window Help

k-EBEF- @ 5P~ Trebuchet MS, Helvetica, ~

Folder List SRRl ® % Site View | indexhtml
B c‘l)urse.menu.html ; 2@)» @@ S

Saving and Publishing
PDF files \—) \F) [ .~ Libraries ~ Documents v sbooth ~ 00.IT Coord ~ Handouts
With the Save as

command in Word 2007

Organize v  New folder

or Word 2010 you may (W] viaosoftword  —{ Documents library
save your Word files as | Templates Handouts

PDF and publish them on

your web site. This works ' Favorites o

very well for files with B Desktop _| T creating Assessments
extensive text or forms 4 Downloads ﬁ-} Excel for Grading Workshop
that users may want to =i| Recent Places X ExpressionWeb-BriefGuide
print. You must, however, X FAQ for Class Email

keep the original word f;%"’L_ibraries 73_1 FAQ for Online Discussion
file if you want to make _[J Documents |4l

changes; you cannot o

create or edit the PDF file File name: | Expression\eb-BriefGuide

with Expression Web. Save as type: [PDF
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Add Hyperlinks to Your Page

To link to a file or another web page
1. Highlight the text you want to have the link associated with.

2. Then right-click on the highlighted text and select Hyperlink from the menu, or select
Insert > Hyperlink from the menu bar to open the dialog box.

3. To link to an external web page, navigate to that page in the browser, select the link (the
complete address including http://); copy it; then go back to the link dialog box and
paste the URL into the Address box.

4. Tolink to afile, click on the file you want to link to. If you want to link to an e-mail
address, click on the E{mail Address button to display the dialog box.

5. Toopen a link in a new window, click on Target Frame... in the Insert Hyperlink dialog
box and select New Window. Then click OK.

21
Link to: Text to display: [Fauity \ ScreenTip... |
e - | =
Look in: Ij‘ Ihttp://www.qcc.mass.edu/english _V_I EI y (=
(&l fefPrac Bookmark... |
. [onebook
Target Frame... |

! .| images
Place in This image
Document Browsed files Parameters... I

Pages | _themes

x;. , _private
Create New Recent . fpdlass
Document Files http://www.qcc.mass.edu/english/index.html {open)

| http://www.qcc.mass.edu/english/faculty.html (open) LI

ﬂ |facu|ty.htm| L‘ Remove Link |
E-mail Address
| OK I Cancel |

Address:

Images for your site may be found in Google’s Advanced Image Search.

Hundreds of clip art images are in public domain, but for others you need to pay attention to
copyright. Once you find a suitable image, right click on the image, select “Save picture as” and
then save the file to a folder on your desktop. You may then copy and paste the file to the
images folder in you web site.

You may change the name of the file you save but not the file extension—

usually .JPG, .GIF, or .PNG

Access http://images.google.com/ and then select Advanced Image Search.
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http://images.google.com/

Brief Guide to Expression Web

Insert an Image

1. Click on the image file in the Expression Web Folder List (it should be in the folder named
images), then drag and drop it onto your web page where you want it.
2. Type a brief description of the image in the Alternate text field. This is required for

accessibility.

Use Tables for Page Layouts

Insert a Table

When you want text blocks or graphics to show up in a particular place, insert a table and place
all the text or graphics within cells of the table. This will also enable your pages to “size” or
“float” to whichever size monitor screen your viewer is using.

1. Make sure your
insertion point is where
you want the table to
be and go to the Table
menu:

Table > Insert Table

2. From the Insert Table
dialog box, enter the
table size you want, as
measured by the
number of rows and
columns. Specify width
in percentages (80%
works well), not pixels,
and then click the OK
button.

3. Enter text into the
table either by typing or
copying and pasting
from a Word Document
into the cells you wish
to use.

Edit Table Properties

2)X]

Insert Table

Size

4

Rows: 2 Columns: |2

Layout
Alignment: Default v | [V]Specify width:
() In pixels

irpefault v | ;80[ Gt

Float:

Cell padding: 1 = [1specify height:

<>

Cell spacing: 2

Borders

Size: \a

4>

Color: | v
[[]collapse table Forie

Background
Color: | Vil

[Juse background picture

Browse...

Set
[]set as default for new tables

[ OK J [ Cancel J

To edit the table’s properties, right-click on the table and select Table Properties from the pop-
up menu. From the Table Properties dialog box (the same as the Insert Table box shown on the
previous page), you can change the cell padding and spacing, border sizes and add a
background color. Use the Apply button to preview any action before making it permanent.

www.gcc.mass.edu/booth/it
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Other options for tables can be found using the Table menu item, where you can spilt a cell,
merge two or more cells into one, delete cells, or add more cells. Remember, as with tables,
cells will grow dynamically as data is placed in them.

Edit Cell Properties

You can also change the properties of an individual cell by right-clicking in the cell and selecting
Cell Properties from the pop-up menu. From the Cell Properties dialog box, you can add a
border and change its color, and add background or fill color to that cell.

Creating and Using Bookmarks (or bookmark links)

Bookmarks assist in navigating around a web page by allowing the user to click a link to go to a
particular place in the page and avoid scrolling to find something.

1. Place your curser at the place in the document where you want to assign a bookmark. This is
usually a topic heading or the beginning of a new subject matter or page. From the menu bar,
go to Insert > Bookmark to open the Bookmark dialog box.

2. Give your new bookmark a name—on that identifies this marker for you, the author. Note:
Don’t put spaces or funny characters in bookmark names. Then click the OK button. You now
have a bookmark that you can link to from within this page, or from other web pages.

3. Next you will select the text that will contain the link to the bookmark, then right-click. From
the pop-up menu, select Hyperlink.

4. Once the Hyperlinks Properties box opens, click on the Bookmark button located at the
upper right.

5. The Select Place in Document dialog box will appear. Highlight the bookmark you want to
the link to point to and click the OK button.

Reminders about previewing, saving your work, and closing your account

1. Click on the Preview button in the toolbar to see how your pages will look to your audience.
Remember to always click the Refresh button in your browser to see the most recently saved
version of your page.

2. Save Often! Avoid losing your work by remembering to save frequently, especially when
working live on the server.

3. Close your site

When working live on the college server and you’re ready to quit, you should close the program
by going to File > Close and then respond if you’re prompted to save and close Expression Web
with the X (rather than just clicking on the X without using the File menu).
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